Error: unable to access resume device (LABLE=SWAP-hda5)

Posted on Updated on

I got an error after creating SWAP for my CentOS

unable to access resume(LABLE=SWAP-hda5) Failed

So I removed the swap partition and recreated it. Formatted it as swap.

swapon does work.

but after restarting my desktop the problem will be the same need to mount swap manually.

my fstab contains :
 /dev/hda5               swap                    swap    defaults        0 0

Here is the solution for this:

Check the kernel version:

[root@rc-090 ~]# uname -a
Linux rc-090 2.6.18-194.el5 #1 SMP Fri Apr 2 14:58:35 EDT 2010 i686 i686 i386 GNU/Linux

Remove existing initrd-2.6.18-194.el5.img inside boot

[root@rc-090 boot]# ll |grep "ini"
-rw------- 1 root root 2593391 Aug  7  2010 initrd-2.6.18-194.el5.img
[root@rc-090 boot]# rm -rf initrd-2.6.18-194.el5.img

Then rebuild the file with current kernel

eg :mkinitrd initrd-kernel-version.img kernel-version

[root@rc-090 boot]# mkinitrd initrd-2.6.18-194.el5.img 2.6.18-194.el5

Reboot the machine with the same kernel.

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s